Strumenti Personalizzati

Da GeoGebraWiki.

GeoGebra consente la creazione di strumenti personalizzati dall'utente, basati su una costruzione esistente. Dopo la creazione, uno strumento personalizzato potrà essere utilizzato sia con un puntatore che con un comando nella barra di inserimento. Tutti gli strumenti vengono salvati automaticamente nel file di GeoGebra.

Note: Gli oggetti generati da uno strumento personalizzato non possono essere spostati, anche se sono stati definiti come Punto[ Cammino]. Se è necessario ottenere oggetti che possano essere mossi, definire una lista di comandi ed eseguirli con il comando Esegui.

Creare strumenti personalizzati

Per creare uno strumento personalizzato, utilizzare l'opzione Menu-tools-new.svg Crea nuovo strumento del Menu-tools.svg menu Strumenti.

Salvare gli strumenti personalizzati

Quando si salva una costruzione in un file GGB, tutti gli strumenti creati vengono memorizzati nel file. Per salvare gli strumenti personalizzati in uno o più file separati, utilizzare la finestra di dialogo Gestione strumenti (opzione Menu-tools.svg Organizza strumenti nel Menu-tools.svg menu Strumenti).

Accedere agli strumenti personalizzati

Quando si apre una nuova interfaccia di GeoGebra (selezionando Menu-file-new.svg Nuovo nel menu Menu-file.svg File) dopo la creazione di uno strumento personalizzato, tale strumento farà parte della barra degli strumenti di GeoGebra. Se invece si apre una nuova finestra di GeoGebra, selezionando l'opzione Menu New.png Nuova finestra nel Menu-file.svg menu File), oppure si apre una nuova sessione del programma, dopo una precedente chiusura, lo strumento non sarà più presente nella barra degli strumenti.

Per fare in modo che gli strumenti personalizzati vengano visualizzati nella barra degli strumenti di GeoGebra: dopo avere creato uno strumento personalizzato, salvare le impostazioni utilizzando la voce di menu Menu-file-save.svg Salva impostazioni del Menu-options.svg menu Opzioni. Da questo momento in poi, lo strumento creato farà parte della barra degli strumenti di GeoGebra.

Note: Per rimuovere lo strumento personalizzato dalla barra degli strumenti, selezionare Menu-tools-customize.svg Personalizza barra degli strumenti nel Menu-tools.svg menu Strumenti, selezionare lo strumento desiderato dall'elenco visualizzato nella finestra di dialogo, a sinistra, quindi fare clic sul pulsante Rimuovi (versione desktop) o trascinare l'elemento nell'elenco a destra (versione Web e app per tablet). Non dimenticare di salvare le impostazioni dopo la rimozione dello strumento personalizzato.

Importare strumenti personalizzati

Dal momento in cui uno strumento personalizzato viene salvato nel computer (in un file GGT), è possibile importarlo in qualsiasi istante in ogni nuovo file di GeoGebra. Basta selezionare Menu-file-open.svg Apri nel Menu-file.svg menu File e aprire il file dello strumento personalizzato.

Note:
  • L'apertura di un file di strumento GeoGebra (GGT) non ha effetto sulla costruzione corrente: rende solo lo strumento disponibile nella barra degli strumenti.
  • Il file GGT può essere aperto anche trascinandone e rilasciandone l'icona nella finestra di GeoGebra.
  • GeoGebra
  • Help
  • Partners
  • Contact us
    • Feedback & Questions
    • This e-mail address is being protected from spambots. You need JavaScript enabled to view it.
    • +43 677 6137 2693
© 2016 International GeoGebra Institute